modification fichier php.ini

Discussion dans 'Discussions Générales' démarrée par frank, Jui 16, 2010.

  1. frank

    frank New Member

    bonjour,

    est-il possible de modifier le fichier php.ini de son installation. je voudrais pouvoir retirer l'option "magic_quotes_gpc" et changer l'option "mbstring.internal_encoding" mias je n'ai pas trouver ou faire ca avec cPanel. merci pour votre aide.
     
  2. AsTr0

    AsTr0 Member

    La configuration d'un serveur mutualisé est propre au serveur et non a ton compte hébergement.(in-changeable pour moi)

    Contact quand même le support pour en être certain!
     
  3. PH-Saber

    PH-Saber Administrator Membre de l'équipe

  4. frank

    frank New Member

    merci. ca marche impeccable.
     
  5. AsTr0

    AsTr0 Member

    Ho c'est plus ou moins nouveau sa , car au début il n'y avais pas la possibilité de le faire!
     
  6. steevecha

    steevecha New Member

    tutoriel php.ini non trouvé

    Bonjour,

    je ne trouve pas le tutoriel sur le php.ini avec le lien que vous avez donné.

    Merci.
     
  7. pierre_kuhn

    pierre_kuhn New Member

  8. steevecha

    steevecha New Member

    merci pour le lien.
     
  9. phil

    phil Member

    Bonjour Pierre ,

    je viens de regarder le lien d´informations que vous avez mis .

    Ce qui m´intéresse est cette ligne: php_value upload_max_filesize 20M

    Je suis sur WP et en ouvrant le fichier .htaccess voilà ce que j´ai mis:

    # BEGIN WordPress

    php_value upload_max_filesize 1000M

    # END WordPress

    Je pense que ce n´est pas correcte , car il n´y a aucun changement sur ma page .

    Pourriez-vous m´indiquer avec plus de précision comment faire ?

    D´avance merci......

    PS:je ne suis qu´un novice dans ce domaine......
     
  10. David77

    David77 Member

    Bonjour,

    Dans ton cPanel, en bas tu as "Sélectionner une version de PHP", clique dessus

    Sur la page suivante en haut à droite tu as "Switch To PHP Settings", clique dessus

    A partir de cette page tu peux régler des paramètres PHP pour l'ensemble de ton hébergement


    Pour les modifier sur un site en particulier, si tu bosse avec des sous-domaines ou domaines compagnons, la méthode htaccess est la mieux
    Pour ton cas j'ai une ligne comme ceci dans le htaccess d'un sous-domaine :
    Code:
    php_value upload_max_filesize 300M
    php_value post_max_size 300M
    Et cela fonctionne sans soucis sur le site concerné

    Essaie en plaçant ces lignes tout en haut de ton htaccess
     
  11. phil

    phil Member

    Bonjour David,

    merci pour le coup de pousse .Je suis devant la page qui apparaît après avoir cliqué sur "sélectionner la version PHP", mais la seule chose que je puisse faire est changer de version PHP (5.1 , 5.2 ETC...)

    A droite "set as current" , j´ai : Warning: Changing php modules and php options via PHP Selector for native php version is impossible

    J´ai donc changé par la version 5.5 et voilà ce que j´ai mis pour tester la valeur à 512 : (lien screenshot ci dessous)

    http://i39.servimg.com/u/f39/17/93/51/86/size_v10.jpg

    Je retourne donc sur mon "tableau de bord " WP, mais il me dit toujours que le max size est de 2,0MB (LIEN SCREEN CI DESSOUS)

    http://i39.servimg.com/u/f39/17/93/51/86/file_s10.jpg

    Je décide donc d´éditer le fichier .htaccess. Voilà ce que j´ai dedans :

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>
    # BEGIN WordPress



    # END WordPress


    Où dois-je mettre les lignes que tu m´indiques ?

    php_value upload_max_filesize 300M
    php_value post_max_size 300M


    Encore merci pour le support ;)

    PS: Non il ne s´agit pas de sous domaine
     
    Dernière édition: Aou 23, 2014
  12. phil

    phil Member

  13. David77

    David77 Member

    Pense à remettre la version native de php dans le cPanel

    Pour l'erreur regarde dans le fichier error_log à la racine de ton site pour avoir plus de détails ;)
     
  14. phil

    phil Member

    Version native remise et le détail du fichier log ci dessous.....

    [29-Jun-2014 11:43:13 UTC] PHP Warning: strpos() [<a href='function.strpos'>function.strpos</a>]: Offset not contained in string in /home/renderpr/public_html/acsgt.net/wp-content/plugins/wordpress-social-login/hybridauth/Hybrid/thirdparty/OpenID/LightOpenID.php on line 87
    [29-Jun-2014 11:43:13 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/renderpr/public_html/acsgt.net/wp-content/plugins/wordpress-social-login/hybridauth/Hybrid/thirdparty/OpenID/LightOpenID.php:87) in /home/renderpr/public_html/acsgt.net/wp-includes/pluggable.php on line 861
    [29-Jun-2014 11:43:13 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/renderpr/public_html/acsgt.net/wp-content/plugins/wordpress-social-login/hybridauth/Hybrid/thirdparty/OpenID/LightOpenID.php:87) in /home/renderpr/public_html/acsgt.net/wp-includes/pluggable.php on line 862
    [29-Jun-2014 11:43:13 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/renderpr/public_html/acsgt.net/wp-content/plugins/wordpress-social-login/hybridauth/Hybrid/thirdparty/OpenID/LightOpenID.php:87) in /home/renderpr/public_html/acsgt.net/wp-includes/pluggable.php on line 863
    [29-Jun-2014 11:43:13 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/renderpr/public_html/acsgt.net/wp-content/plugins/wordpress-social-login/hybridauth/Hybrid/thirdparty/OpenID/LightOpenID.php:87) in /home/renderpr/public_html/acsgt.net/wp-includes/pluggable.php on line 1121
    [29-Jun-2014 12:19:24 UTC] PHP Warning: strpos() [<a href='function.strpos'>function.strpos</a>]: Offset not contained in string in /home/renderpr/public_html/acsgt.net/wp-content/plugins/wordpress-social-login/hybridauth/Hybrid/thirdparty/OpenID/LightOpenID.php on line 87
    [29-Jun-2014 12:21:12 UTC] PHP Warning: strpos() [<a href='function.strpos'>function.strpos</a>]: Offset not contained in string in /home/renderpr/public_html/acsgt.net/wp-content/plugins/wordpress-social-login/hybridauth/Hybrid/thirdparty/OpenID/LightOpenID.php on line 87
    [29-Jun-2014 12:22:14 UTC] PHP Warning: strpos() [<a href='function.strpos'>function.strpos</a>]: Offset not contained in string in /home/renderpr/public_html/acsgt.net/wp-content/plugins/wordpress-social-login/hybridauth/Hybrid/thirdparty/OpenID/LightOpenID.php on line 87
    [29-Jun-2014 12:31:35 UTC] PHP Warning: strpos() [<a href='function.strpos'>function.strpos</a>]: Offset not contained in string in /home/renderpr/public_html/acsgt.net/wp-content/plugins/wordpress-social-login/hybridauth/Hybrid/thirdparty/OpenID/LightOpenID.php on line 87
    [29-Jun-2014 12:35:30 UTC] PHP Warning: strpos() [<a href='function.strpos'>function.strpos</a>]: Offset not contained in string in /home/renderpr/public_html/acsgt.net/wp-content/plugins/wordpress-social-login/hybridauth/Hybrid/thirdparty/OpenID/LightOpenID.php on line 87
    [29-Jun-2014 12:54:18 UTC] PHP Warning: strpos() [<a href='function.strpos'>function.strpos</a>]: Offset not contained in string in /home/renderpr/public_html/acsgt.net/wp-content/plugins/wordpress-social-login/hybridauth/Hybrid/thirdparty/OpenID/LightOpenID.php on line 87

    Donc rien concernant mon problème actuel....

    J´ai ouvert un ticket.......
     
  15. phil

    phil Member

    Bon je regarde partout sur le net pour essayé de trouver une solution à mon problème

    -Le .htaccess est bien paramétré:

    Options -Indexes
    # BEGIN WordPress
    php_value upload_max_filesize 200M
    php_value post_max_size 200M
    php_value max_execution_time 300
    php_value max_input_time 600
    # END WordPress


    -La version est remis sur la version native

    Le truc bizarre est que ce matin , j´ai eu une assistance de planet hoster via "chat" et cela à fonctionné. J´ai pu uploader deux fichier et tout de suite après j´ai commencé à avoir ce message: HTTP error
     
  16. David77

    David77 Member

    Malheureusement je ne maitrise pas WP :(

    Mon aide s'arrête donc là pour ton problème....
     
  17. phil

    phil Member

    Merci pour ton coup de pousse ;)
     
  18. phil

    phil Member

    De retour ,

    alors j´ai la solution au problème.........Après plus d´une journée a essayer de solutionner le problème....Et bien l´hébergement mutualisé ne permet que d´uploader des fichiers de taille maximum de 128 MB.

    Maintenant , je rencontre un autre problème. Lorsque j´uploade des fichiers de 30/40 MB ça passe mais des que je dépasse cette taille (sans exéder 128 MB bien sur) j´ai encore le message HTTP error .

    Même le support ne trouve pas la solution .....( encore merci à eux pour le temps passé dessus )

    Please help me !! lol
     
  19. phil

    phil Member

    Bonjour à tous,

    je me permet de poster ici car je me trouve face à un ce même problème je pense :
    "Are you sure you want to do this"

    Cela arrive lorsque je tente d´uploader un nouveau theme wordpress.

    Je trouve différente chose :
    -Modifier ou créer un fichier php.ini avec cela de dans:
    upload_max_filesize = 100M
    post_max_size = 200M
    max_execution_time = 180

    Soit, modifier le fichier .htaccess

    Dans les deux cas, cela ne fonctionne pas chez moi.

    Je suis sur un plan mutualisé.

    D´avance merci pour votre aide.
     
  20. David77

    David77 Member

    Bonjour,
    Alors pour modifier ces variables tu peux soit modifier le htaccess :
    Code:
    php_value memory_limit 2048M
    php_value upload_max_filesize 300M
    php_value post_max_size 300M
    Soit depuis ton cPanel modifier le php.ini de ton compte (même sur un mutualisé car j'en ai un aussi)
    Pour cela tu teconnectes à ton cPanel, puis tu vas sur "Éditeur INI MultiPHP" (ou tape ini dans la zone de recherche du cPanel en haut)

    Ensuite tu peux modifier le ini d'un domaine en simple editeur ou simplifié
    C'est assez intuitif

    Bien sûr à utiliser avec précaution ;)
     
    Dernière édition: Sep 25, 2017

Partager cette page