Modification "memory_limit"

Discussion dans 'Hébergements Mutualisés' démarrée par David77, Déc 17, 2011.

  1. David77

    David77 Member

    Bonsoir,

    Je me permet de poster ici ma demande car je n'ai pas eu de réponse à ma demande d'aide par le support :(

    J'ai actuellement ce message d'erreur sur un site de vente en ligne:
    Je précise que c'est un sous-domaine (shop.domaine.com).

    J'ai essayé de modifier la valeur de "memory_limit" via le .htaccess (à la racine du sous-domaine) avec ce code :
    Code:
    php_value memory_limit 256M
    Ce code ne fonctionnant pas j'ai ajouté un fichier php.ini à la racine du sous-domaine concerné avec ce code :
    Code:
    [PHP]
    memory_limit = 256M
    Mais le message d'erreur est toujours présent.

    Il s'agit d'un site de vente en ligne vendant des cours téléchargeable hors à l'heure actuel il est impossible de télécharger les fichier après achat à cause de cette erreur.

    Je vous remercie par avance pour votre aide.
     
    Dernière édition: Déc 18, 2011
  2. David77

    David77 Member

    Je viens d'essayer une 3eme méthode qui consiste à modifier le fichier concerné en lui ajoutant ceci:
    Code:
    ini_set('memory_limit','256M');
    Mais ça ne fonctionne toujours pas :(

    Je suis vraiment bloqué et j'ai besoin de modifier cette valeur pour que cette boutique fonctionne :(
     
    Dernière édition: Déc 18, 2011
  3. David77

    David77 Member

    Je viens de vérifier la valeur de "memory_limit" dans un phpinfo et j'ai bien:
    • Local Value : 256M
    • Master Value : 256M

    Pourtant j'ai toujours le message d'erreur :
     
  4. pierre_kuhn

    pierre_kuhn New Member

    Bonjour

    Tu as modifier quel fichier ? par ce que phpinfo ça me dis rien alors que php.ini oui et c'est ce fichier qu'il faut modifier ou créé.
     
  5. David77

    David77 Member

    phpinfo te permet de vérifier la configuration de php.ini.

    J'ai modifier le .htaccess en ajoutant ce code (comme expliqué dans la FAQ) :
    Code:
    php_value memory_limit 256M
    J'ai mis un fichier php.ini à la racine du sous-domaine avec ce code :
    Code:
    [PHP]
    memory_limit = 256M
    Et enfin j'ai ajouté ce code au fichier php qui est cité dans le message d'erreur:
    Code:
    ini_set('memory_limit','256M');
    Mais malgré toutes ces manipulations l'erreur est toujours là....

    Chez mon ancien hébergeur ça fonctionnait mais je ne sais pas ce qu'il avait fait lorsque je lui avait fait part de ce même problème...

    Cette boutique en ligne est sous Prestashop (qui est quand même assez réputé) mais tout ce que j'ai pu trouver comme explication c'est faire changer la valeur de cette variable, d'où ma demande d'aide :(
     
  6. pierre_kuhn

    pierre_kuhn New Member

    tu les fait en même temps ou pas car ça serais fonctionner à moins que tu le mette pas au bon endroit aussi.

    tu pensent a vider tes caches aussi ? une url ?
     
    Dernière édition: Déc 18, 2011
  7. David77

    David77 Member

    J'ai essaye ca les uns apres les autres....
    Comme le site concerne est un sous-domaine d'un domaine compagnon au domaine principal de mon offre je ne sais pas trop ou placer ces fichiers meme si le .htaccess doit etre dans le dossier contenant le fichier.

    Je peux te donner l'url du site mais tu ne pourras rien faire car il faut acheter le pack pour pouvoir le telecharger....
     
  8. pierre_kuhn

    pierre_kuhn New Member

    Je connais pas ton architecture de plan ;) donc je sais pas ou ça se place, ton htaccess dois déjà exister dans ton cms suffit de rajouter la ligne dedans.

    Honnêtement je connais pas prestachop car le jour ou je l'installer, le serveur a couler donc je retenterais pas tous de suite.

    Et quand je demande url, c'est l'url de ton site pas celui de ton cms.

    /me aime que les logiciel gratuit
     
  9. David77

    David77 Member

    Je pense que quelque soit le plan l'architecture et la démarche reste la ou les même... Mais ça ne fonctionne pas... Et franchement c'est très angoissant :s

    Si tu veux voir le site c'est à cette adresse: Le CESA - La Boutique

    Mais tu ne pourras pas voir l'erreur... (et prestashop est entièrement gratuit ;-) )

    Par contre je comprends pas pourquoi je n'ai aucune réponse des techniciens... Pourtant on m'avait vanté principalement le support hyper réactif :-(
     
  10. David77

    David77 Member

    Bon mon 1er ticket ouvert le 17 décembre, réponse hier:
    Alors que nous ça ne marche toujours pas :mad:
    Je fais quoi moi maintenant!? J'ai répondu au ticket mais aucune réponse!
    20mn d'attente au téléphone sans réussir à avoir quelqu'un au bout du fil !!!!!!!

    J'avais choisi PH car le support était mis en avant partout, je commence à croire que je me suis fait avoir en beaté et que tous ces fameux avis positif s étaient tous bidon, et une sorte de SPAM positif :mad:

    N'y a-t-il personne de PH qui consulte le forum!?
    Une personne aurait l'adresse mail d'une personne du support technique!?
     
  11. AsTr0

    AsTr0 Member

    Quel CMS utilise-tu pour utiliser 256Mo/page ? <_<'

    Quand tu aura plein de visiteurs il te faudra un serveur dédier :-D

    Regarde a l'optimisation de ton script :-D
     
  12. David77

    David77 Member

    le CMS est prestashop... et ce n'est pas 256Mo/page mais un fichier à télécharger si il est acheté....
     
  13. PH-Saber

    PH-Saber Administrator Membre de l'équipe

    Bonjour,

    Merci pour votre retour,

    J'ai apporté certains correctifs sur votre compte, est-ce que le problème persiste toujours svp?
     
  14. David77

    David77 Member

    Bonjour,

    En effet il y a du changement puisque mon compte a été suspendu....

    Est-ce possible d'avoir des explications????

    Les techniciens m'ont proposé d'ouvrir GRATUITEMENT un compte test sur un serveur PHP 5.2.
    Je reçois une facture pour ce compte, je poste un ticket demandant des explications et aucune réponse; et aujourd'hui on me suspend le compte test parce que je n'ai pas réglé une facture pour un service proposé gratuitement pour faire des tests!?

    En plus le compte test a été ouvert avec un domaine qui est déjà hébergé en domaine compagnon sur mon compte principal (que j'ai payé pour 1 an), résultat en suspendant le domaine ils n'ont pas suspendu que le compte test mais aussi le "bon" site qui était "fonctionnel" !!!

    Même pas un mois que je suis chez PlanetHoster et 2 problèmes d'envergure....
     
    Dernière édition: Déc 30, 2011
  15. PH-Saber

    PH-Saber Administrator Membre de l'équipe

    Bonjour David,

    Merci pour votre retour, cela concerne le renouvellement de lecesa.com pour la période suivante: (28/12/2011 - 27/12/2012) . La facture du renouvellement ne semble pas avoir été réglée.

    Je vous invite svp à me contacter par courriel: saber@planethoster.info , je vais regarder ceci pour vous.
     
  16. David77

    David77 Member

    Email envoyé.

    Le compte "lecesa.com" a été ouvert pour test justement, sur proposition des techniciens.
    Car le domaine "lecesa.com" est déjà enregistré sur un autre compte (sur un plan performance) en tant que domaine compagnon............
     
  17. David77

    David77 Member

    Je vous ai envoyé des emails à l'adresse donnée mais aucune réponse quant à présent....
     
  18. pierre_kuhn

    pierre_kuhn New Member

    David77 Il dort là ;)

    Faut attendre 19h maintenant ;)
     
  19. David77

    David77 Member

    ah ok....

    mais je pensais que pour gérer les tickets (et non pas les demandes via ce forum), il y avait toujours quelqu'un?

    je suis en train de me bouffer les doigts (déjà plus de cheveux) depuis 15 jours pour un problème technique dont personne ne comprend l'origine....
    j'espère pouvoir le contacter soit via email, soit skype, même le téléphone si il le faut !

    bon quant il sera débout alors ;)
     
  20. pierre_kuhn

    pierre_kuhn New Member

    J'avais compris que tu avais envoyer un mail, si c'est un mail a Saber, lui il dors mais pour les tickets c'est sur du 24h/24h par contre.

    Mais comme je mètrise pas ton problème complétement, je pourrais pas te guider.
     
  21. David77

    David77 Member

    je sais bien ;-)

    surtout que nous avons déjà essayé tout ce qui était possible (y compris le smanip que tu m'avais indiqué et que j'avais déjà faites) à mon sens....

    Mais le support par ticket répond que le lendemain... et encore.... Simon que j'avais eu au téléphone (avec beaucoup de mal, et en passant par le choix "anglais") m'a dit qu'ils étaient en effectif réduit pour les fêtes....
     
  22. pierre_kuhn

    pierre_kuhn New Member

    Et moi je devais les rejoindre par contre ;)
     
  23. David77

    David77 Member

    bah un contact direct sur notre fuseau horaire serait appréciable....

    bientôt peut être ;)
     
  24. pierre_kuhn

    pierre_kuhn New Member

    eh ouai
    Faut que je les bouge à ce sujet ;)
     
  25. David77

    David77 Member

    Un énorme MERCI à Saber qui m'a appelé et qui a pu résoudre mon problème en quelques secondes...

    Il s'agissait d'un problème avec "LiteSpeed" qui ne prenait pas en compte mes modifications du paramètre "memory_limit"....

    Merci encore Saber :D

    Par contre Saber est-ce que le problème risque de se reposer si à l'avenir je souhaite modifier un paramètre de la même façon?
     
  26. pierre_kuhn

    pierre_kuhn New Member

    Si tu as eu Saber au téléphone et qu'il a corriger le soucis, normalement tu as plus de soucis pour les modifiers car il aura fait remonter le soucis à "LiteSpeed" pour correction de leur script.
     

Partager cette page