Problème d'envoi et de réception de messages

Discussion dans 'Discussions Générales' démarrée par Psykie, Oct 29, 2010.

  1. Psykie

    Psykie New Member

    Bonjour à tous,

    Je me bats depuis ce matin sans résultats, donc je poste ici en espérant obtenir une aide.

    Mon site est hébergé depuis quelques jours sur Planet Hoster, et tout ce qui fonctionnait en local ne fonctionne plus sur le web.

    Je m'explique. Sur mon site, j'ai un formulaire de contact, ainsi que la possibilité pour un utilisateur ayant oublié son mot de passe, d'en recevoir un nouveau, tout cela via un script php.

    Sur mon site en version serveur local, j'utilisais ceci :

    <?php

    ini_set('SMTP', 'smtp.free.fr');
    ini_set('smtp_port', '25');
    ini_set('sendmail_from', 'mon-email@free.fr');

    ?>

    afin de paramétrer mon php.ini et cela fonctionnait impeccable via la fonction mail()

    Comme sur mon site je souhaite utiliser une adresse contact@mon-domaine.fr , j'ai créé cette adresse, et j'ai configuré mon logiciel de messagerie Outlook Express en IMAP, en téléchargeant la petite application toute prête.

    Ca a fonctionné, car ce compte apparaît bien désormais sur mon Outlook Express, avec les infos suivantes:

    serveur entrant IMAP : mail.mon-domaine.fr
    serveur sortant SMTP : mail.mon-domaine.fr

    port SMTP : 25
    port IMAP : 143

    serveur messagerie pour courrier entrant : contact@mon-domaine.fr


    Seulement j'ai beau modifié les infos de mon code (voir code plus haut), rien ne fonctionne. Je ne reçois ni de mail du formulaire de contact, et quand je feins d'être un utilisateur ayant oublié son mot de passe et que j'en demande un nouveau, rien ne parvient non plus.

    Je ne trouve aucun tuto, ni ici, ni sur internet, afin de parvenir à ce que cela fonctionne.

    Merci d'avance de votre aide
     
  2. AsTr0

    AsTr0 New Member

    La fonction mail est plus simple que la SMTP !

    mail($to, $subject, $message);

    A pluch
     

Partager cette page