urlrewriting qui focntionne en local mais pas chez Planethsoter

Discussion dans 'Discussions Générales' démarrée par sam01, Oct 22, 2010.

  1. sam01

    sam01 New Member

    Bonjour,

    j'effectue un url rewriting en mettant dans mon .htaccess

    Code:
    
    RewriteRule ^mess-reception-mess-([a-z]+).\html$ mess-reception.php?mess=$1  [L] 
    
    
    dans mon php, j'ai

    echo '<a href="'.$site.'mess-reception-mess-env.html">'.$idem_txt0158.' </a>';

    Ca me donne génère l'erreur suivante

    Not Found

    The requested URL /mess-reception-mess-env.html was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/2.2.16 (Unix) mod_ssl/2.2.16 OpenSSL/0.9.8e-fips-rhel5 FrontPage/5.0.2.2635 mod_bwlimited/1.4 mod_auth_passthrough/2.1 mod_perl/2.0.4 Perl/v5.8.8 Server at www.swapnfly.com Port 80


    Alors qu'en local avec easyphp ça fonctionne parfaitement....
     
  2. AsTr0

    AsTr0 New Member

    Dans ton htacces tu doit passer le url rewite a on ;)
     
  3. grifos

    grifos New Member

    Bonjour,
    Je déterre ce sujet car je suis exactement dans la même situation que l'utilisateur ayant originalement posté le topic.
    Je possède un hébergement mutualisé illimité.
    Mon site ce trouve dans un dossier: "mon_site" situé dans /home/nom/public_html/

    J'utilise le code suivant dans mon htaccess
    Code:
    RewriteEngine On
    RewriteBase /home/nom/public_html/mon_site
    RewriteRule ^([a-z\-]+)/?$ index.php?page=$1 [NC,QSA]
    Ce code marche très bien en local, sur ma configuration de dev (wamp2)

    Seulement cela ne fonctionne pas sur mon hebergement, j'obtient l'erreur:
    HTML:
    Not Found
    
    The requested URL /home/nom/public_html/mon_site/index.php was not found on this server.
    
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Je suis coincé, car sur certain site il est dis que c'est dût au fait que mod_rewrite n'est pas lancé, mais on ma fait comprendre via un ticket support que le mod_rewrite était bel est bien présent.

    En espérant que vous puissiez m'aider.
    Cordialement
     
  4. PH-Saber

    PH-Saber Administrator Membre de l'équipe

    Bonjour,

    Merci d'avoir choisi PlanetHoster. Le URL rewriting fonctionne normalement sans problème chez PlanetHoster.

    Svp, assurez-vous d'utiliser votre nom de domaine. Si vous utilisez l'adresse ip temporaire, le url rewrite ne sera pas entièrement fonctionnel.

    Si le problème persiste, svp, n'hésitez pas à nous contacter.

    Bonne journée à vous,
     
  5. grifos

    grifos New Member

    J'utilise un nom de domaine compagnon pour accéder à mon site, peu être cela vient il de là.

    Cordialement
     
  6. PH-Saber

    PH-Saber Administrator Membre de l'équipe

    Bonjour,

    Pouvez-vous svp nous fournir le contenu du .htaccess utilisé ? Nous allons regarder ceci pour vous.

    Bonne journée à vous,
     
  7. AsTr0

    AsTr0 New Member

    Salut!

    Ton problème viens d'ici :

    RewriteEngine On
    RewriteBase /home/nom/public_html/mon_site

    Remplace le simplement par

    RewriteEngine On
    RewriteBase /

    Voilà
     
  8. grifos

    grifos New Member

    Merci de votre aide, mais j'ai fini par faire marcher l'url rewriting. C'était dût à l'erreur suivante:
    Code:
    RewriteEngine On
    RewriteBase /home/nom/public_html/mon_site
    RewriteRule ^([a-z\-]+)/?$ index.php?page=$1 [NC,QSA]
    Le rewrite base marche, cependant j'ai oublié un slash pour la rewrite rule.
    Ce qui devient:

    Code:
    RewriteEngine On
    RewriteBase /home/nom/public_html/mon_site
    RewriteRule ^([a-z\-]+)/?$ /index.php?page=$1 [NC,QSA]
    Je n'ai pas testé ta méthode Astr0 mais je suppose qu'elle doit marcher aussi =)

    Cordialement
     
  9. AsTr0

    AsTr0 New Member

    Je suis content pour toi que sa marche :)
     
  10. Karigura

    Karigura New Member

    Cela ne fonctionne pas pour moi

    Bonjour, j'ai le même problème, j'ai beau activer la réecriture mais cela ne change rien.
    Voici mon code:

    PHP:
    SetEnv PHP_VER 5
    SetEnv REGISTER_GLOBALS 0

    <IfModule mod_rewrite.c>
    Options +FollowSymLinks
    RewriteEngine On
    RewriteBase 
    /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule index
    .php favoris.php
    RewriteCond 
    %{REQUEST_FILENAME} !-d

    RewriteRule 
    ^(.*)-t-([0-9]*).html(.*)$   Affichage.php?id=$2$[L]
    RewriteRule ^(.*)-p-([0-9]*).html(.*)$   pages.php?id=$2$[L]

    </
    IfModule>

    Je souhaite que le client arrive directement sur la page favoris.php du site, et non index.php.
    j'ai donc inséré
    RewriteRule index.php favoris.php

    Mais cela ne change rien.

    Quelqu'un comprend il mieux que moi ?

    Merci d'avance !!
     
  11. pierre_kuhn

    pierre_kuhn New Member

    Bonjour

    Et une redirection 301 dans le index.php ?
     
  12. Karigura

    Karigura New Member

    Parfait !

    Ça fonctionne impeccablement !!
    Merci !!! :D
     
  13. pierre_kuhn

    pierre_kuhn New Member

    Bonjour

    Tu peux le faire aussi dans un index.html si tu veux garde le .php pour le site.
     

Partager cette page