VPS: Edition du php.ini impossible en ssh

Discussion dans 'VPS / Dédiés / HybridCloud' démarrée par ccvf2s, Jan 29, 2015.

  1. ccvf2s

    ccvf2s New Member

    Bonjour,

    Je me joins à ce forum parce que je n'arrive pas éditer mon php.ini quand je suis en ssh

    effectivement je me connecte à mon serveur vps avec mon compte cpanel mais malheureusement,
    je n'arrive pas à éditer le fichier.

    Effectivement celui ci est en lecture seule, du coup j'essaye de le faire avec root;
    mais cela ne marche pas.

    Car je n'arrive pas à me connecter avec root, quand je fais ssh root@mon-server -p 2908, celui ci se déconnecte automatiquement.

    Alors je me suis dit que j'allais me connecter d'abord avec mon compte normal puis switché vers root afin de pouvoir le faire.
    Mais cela ne marche pas aussi.

    Car après avoir ajouté l'utilisateur dans le wheel group, je me connecte avec et ensuite je fais la commande 'su' qui me demande le mot de passe du root mais après avoir tapé le bon mot de passe, vu que je sais que celui ci marche très bien quand je me connecte à l'interface du WHM, cela me dit "Mot de passe incorrect".

    Après de multiples recherches, je ne sais plus quoi faire, j'ai vraiment besoin de modifier le fichier php.ini afin de pouvoir utiliser composer.phar qui ne s'exécute pas sur mon serveur et dont le message est:

    Some settings on your machine make Composer unable to work properly.
    Make sure that you fix the issues listed below and run this script again:

    The suhosin.executor.include.whitelist setting is incorrect.
    Add the following to the end of your `php.ini` or suhosin.ini (Example path [for Debian]: /etc/php5/cli/conf.d/suhosin.ini):
    suhosin.executor.include.whitelist = phar

    The php.ini used by your command-line PHP is: /usr/local/lib/php.ini
    If you can not modify the ini file, you can also run `php -d option=value` to modify ini values on the fly. You can use -d multiple times.

    La commande php -d génère une érreur elle aussi, je ne peux malheureusement pas créer de fichier suhosin.ini problème de droit aussi.

    et sudo me génère cette érreur: sudo: effective uid is not 0, is sudo installed setuid root?

    A savoir aussi, j'ai changé quelques fois le type de shell acces vers normal shell pour avoir tout les droits en ssh sans restrictions mais voilà toujours rien.

    Merci de m'aider s'il vous plaît... Je sais que j'ai beaucoup écrit tout de même
     
  2. ccvf2s

    ccvf2s New Member

    Bien sur j'ai ouvert un ticket dans lequel j'ai émis tous mes problèmes et dont ceux que j'ai fini par résoudre, mais pour cela je ne vois pas du tout comment m'en sortir étant donné que je ne peux accéder à root en ssh car celui ci est bel et bien accessible par WHM.
     
  3. ipefix

    ipefix New Member

    As-tu essayé de te connecter à ton root via ftp ? php.ini est rangé dans /usr/local/lib/
     
  4. PH-Jay

    PH-Jay Member

    Vous n'avez pas accès par défaut à l'accès root en SSH, seul notre équipe peut le faire pour des questions de sécurité et nous ne recommandons jamais à nos clients de se connecter en tant que root. Cependant si vous désirez absolument l'accès root ouvrer un ticket et nous vous débloquerons cela.
     

Partager cette page